Sunday, 15 June 2014

perl(DBI) >= 1.13 is needed by percona-toolkit


Percona tool kit is one of the user friendly toolkits for DBA’s which are available in the environment. It has reduced the workload for DBA’s. Percona toolkits have many tool which works for verifying MySQL replication, finding duplicate indexes, summarizing MySQL server and servers etc.




While we install Percona toolkit some of us may face the following issue,


It is due the missing of the mentioned files , in order to overcome the issue we need  to install those files before installing Percona tool kit.

I have given example for Cent-OS 32 bit system,

First we should get the perl(DBI) file, you can get it from here

Once downloaded install it
It is better to run a rpm file with yum command rather than rpm install, as yum will install all missing dependencies along with the file.

# rpm  -Uvh perl-DBI-1.609-4.el6.i686.rpm 


Similarly download the rest of dependencies files and install them using yum

perl(DBD::mysql)

perl(Time::HiRes) 

perl(IO::Socket::SSL) 



The reason for installing with yum is that it will install the missing files as shown


From the image you can see that for perl(IO::Socket::SSL) if we run it with rpm command it will ask for perl-Net-LibIDN & perl-Net-SSLeay packages . After installing those files only we can install the socket package.But with yum it will install those files too.

Once all missing dependencies are installed now you can install Percona toolkit



After installation is finished you can check it by running pt (pt tab key) command ,









No comments:

Post a Comment